Installere Rails FEIL: kunne ikke finne rails lokalt eller i et depot

stemmer
2

Jeg har vært poking rundt Internett på jakt etter en løsning på dette ... uten hell .. Jeg er ny på skinner ... Hvis noen har en idé, vil jeg gjerne høre det. Høyt verdsatt!

Jeg går inn:

LW:src liamwright$ sudo gem install rails --include-dependencies

Og få:

INFO:  `gem install -y` is now default and will be removed
INFO:  use --ignore-dependencies to install only the gems you list
Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR:  could not find rails locally or in a repository

Jeg løper:

ruby 1.8.6 (2008-08-11 patchlevel 287) [universal-darwin9.0]
Mac OS X 10.5.8

Jeg har også prøvd:

gem sources -r gems.rubyonrails.org 

Og få:

source gems.rubyonrails.org not present in cache
Publisert på 30/12/2009 klokken 00:53
kilden bruker
På andre språk...                            


4 svar

stemmer
2

Kanskje vil sørge for at du har de nyeste RubyGems:

sudo gem install rubygems-update
sudo gem update --system

Deretter:

sudo gem install rails
Svarte 30/12/2009 kl. 01:02
kilden bruker

stemmer
2

Bare for å sjekke ...

... prøve å gjøre en sudo gem update --systemfør du installerer Rails å sikre at du har de nyeste RubyGems installert?

EDIT: Egentlig, hvis RubyGems installere er virkelig gamle, må du kanskje å følge alternative retninger på Gemcutter .

Svarte 30/12/2009 kl. 01:04
kilden bruker

stemmer
1

Jeg kom over denne løsningen på Albertux' blox . Kjører dette skriptet vil fikse det (det fungerte perfekt for meg på en Ubuntu 9.10 maskin):

#!/bin/bash
#(download the latest on http://rubyforge.org/frs/?group_id=126)
wget http://rubyforge.org/frs/download.php/43984/rubygems-update-1.3.0.gem
sudo gem install rubygems-update-1.3.0.gem
sudo update_rubygems
# now this work:
sudo gem update --system
echo "done."
Svarte 02/01/2010 kl. 13:25
kilden bruker

stemmer
0

Jeg har bare hatt det samme problemet prøver å oppgradere RubyGems fra 1.2.0 til 1.3.7.

Setp-1) Så jeg bare lastet ned RubyGems-update-1.3.7.gem fra http://rubyforge.org/frs/?group_id=126

Setp-2) perle installere RubyGems-update-1.3.7.gem

Setp-3) update_rubygems

og det fungerer for meg.

Svarte 29/11/2010 kl. 03:55
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more