Løse avhengig for Microsoft.Data.Entity.SqlServer svikter

stemmer
3

Når løse avhengigheter for Microsoft.Data.Entity.SqlServeri en versjon nyere enn 0.1-alpha-build-0863, vs 2014 er ikke løse avhengigheter for denne pakken. Alt fungerer fint når du bruker den tidligere versjonen.

Jeg tror noen endringer i .nuspec filen i pakken er å klandre for dette.

versjon 0.1-alpha-build-0863:

<group targetFramework=.NETFramework4.5>
    <dependency id=Microsoft.Data.Common version=0.1-alpha-build-0137 />
    <dependency id=Microsoft.Data.Entity version=0.1-alpha-build-0766 />
    <dependency id=Microsoft.Data.Entity.Migrations version=0.1-alpha-build-0766 />
    <dependency id=Microsoft.Data.Entity.Relational version=0.1-alpha-build-0766 />
    <dependency id=Microsoft.Data.SqlServer version=0.1-alpha-build-0670 />
    <dependency id=Microsoft.Framework.DependencyInjection version=0.1-alpha-build-0362 />
  </group>

versjon 0.1-alpha-build-1136:

  <group targetFramework=.NETFramework4.5.1>
    <dependency id=Microsoft.Data.Entity.Migrations version=0.1-alpha-build-1136 />
    <dependency id=Microsoft.Data.SqlServer version=0.1-alpha-build-0774 />
  </group>

Det er en avhengighet link fra Microsoft.Data.Entity.Migrationstil Microsoft.Data.Entity.

Redigere:

Avhengigheter er i pakker mappen, men de er ikke oppdaget av vs 2014 CTP og k build.

Publisert på 08/07/2014 klokken 15:08
kilden bruker
På andre språk...                            


1 svar

stemmer
1

Prøv å oppdatere prosjektet å målrette NET 4.5.1, dette løste problemet for meg. Du kan gjøre dette ved å oppdatere din project.json fil fra:

"configurations" : {
    "net45" : { },
    "k10" : { }
},

Til

"configurations" : {
    "net451" : { },
    "k10" : { }
},
Svarte 17/07/2014 kl. 18:46
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more