ASP.NET 5 prosjekt pakker clenaup

stemmer
1

Jeg bruker nyeste nattlig bygge under developmant av min ASP.NET fem prosjekt og møtte følgende problem.

Under publisering har jeg alle tidligere versjoner av pakker publisert i stedet for bare siste (som er spesifisert i project.json).

Så hvis jeg tidligere har brukt Microsoft.AspNet.Mvc: 6.0.0-beta1, Microsoft.AspNet.Mvc: 6.0.0-beta2, Microsoft.AspNet.Mvc: 6.0.0-rc1jeg får dem publisert publish_folder\approot\packages\Microsoft.AspNet.Mvc.

Hvordan kan jeg unngå publisering pakker som ikke brukes i prosjektet lenger?

Publisert på 25/12/2014 klokken 08:14
kilden bruker
På andre språk...                            


1 svar

stemmer
1

Det er ingen problemer lenger, jeg tror denne feilen fikset av Microsoft allerede. Jeg har oppgradert KVM til nyeste RC-versjonen samt alle pakker i prosjektet. For å installere og oppgradere KVM og KRE gjøre følgende:

  1. Åpen Powershell som administrator

  2. Kjør kommando: "Set-ExecutionPolicy RemoteSigned" og bekreft endringer, vil dette tillate kjøring av Powershell script

  3. Clone https://github.com/aspnet/Home repository (i mitt tilfelle er det D: \ GitHub \ Home)

  4. i Powershell-konsoll navigere til D: \ GitHub \ Hjem og kjøre "kvminstall.ps1"

  5. Endre standard innmatingsadresse til dev gren å bruke nyeste pakker

    en. Open "kvm.ps1" for redigering

    b. Gå til linje 41 og sette fôr url: $ fôr = " https://www.myget.org/F/aspnetvnext/api/v2 ";

Hvis du hopper over forrige trinnet, vil du få beta1 versjon av pakker (på tidspunktet for å skrive dette innlegget) i stedet for Release Candidate

  1. Åpne kommando Love (Windows -> Kjør -> cmd)

  2. Naviger til D: \ GitHub \ Hjem

  3. Kjør "kvm oppgradering" (det vil laste ned siste versjon av KRE x86 og angi det som standard

  4. Kjør "kvm opp oppgradere -amd64" for å gjøre det samme for x64 pakker versjon

Svarte 16/01/2015 kl. 06:34
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more