Installere / aktivere PHP "intl" forlengelse kjører MAMP

stemmer
12

Ok, jeg kjører MAMP 1.9.5, som inkluderer PHP 5.3.5, på min MacBook Pro.

Den intl forlengelse er ikke inkludert / aktivert, og jeg har prøvd mange forskjellige måter å installere det ( ./pecl installere intl ser ikke ut til å gjøre det), men kan ikke gjøre det arbeidet.

Jeg har også googlet ræva av, men kan ikke finne noen hint.

Noen av dere som vet hvordan du gjør det? Eller alternativt ha og råd om hvordan du installerer min egen MySQL + Apache + PHP (og inkludere intl)?

Jeg prøver å gjøre dette for å kunne kjøre Symfony2. Så hvis du har noen råd om hvordan du installerer MySQL + Apache + PHP + Symfony2 på Mac, dvs også velkommen :)

Publisert på 29/03/2011 klokken 07:48
kilden bruker
På andre språk...                            


2 svar

stemmer
20

Den beste måten er å laste ned PHP for OSX på http://php-osx.liip.ch/ og deretter kopiere intl.sofilen fra

/usr/local/php5-20121126-100332/lib/php/extensions/no-debug-non-zts-20100525/intl.so

til

/Applications/MAMP/bin/php/php5.4.4/lib/php/extensions/no-debug-non-zts-20100525/intl.so

Virket som en sjarm for meg for PHP 5.4

Svarte 03/01/2013 kl. 09:17
kilden bruker

stemmer
4

Jeg bare utarbeidet på min her om dagen.

Jeg skrev en selv påminnelse innlegget her: http://szemian.wordpress.com/2011/03/21/compiling-intl-extension-for-mamp/

Gi meg beskjed hvis du trenger ytterligere forklaring. :)

Svarte 29/03/2011 kl. 12:43
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more