SIDEKIQ JOBB Kunne men viser i kø i SIDEKIQ STATUS?

stemmer
0

Mitt problem er: Produksjonssystemet var oppdatering til ny versjon. Produksjonen sidekiq var det ikke. På grunn av dette ble ingen jobber behandlet i denne perioden. Etter at produksjonen sidekiq var oppdatering, alle kommende arbeidsplasser ble beeing behandlet på vanlig måte. Men alle tidligere jobber var det ikke.

Når jeg teste dette tilfelle i min lokale maskin alt som ble lagt i kø begynner å kjøre etter oppdateringen av sidekiq.

Nedenfor er den informasjonen som jeg fikk fra produksjon:

stats = Sidekiq::Stats.new
<Sidekiq::Stats:0x000055b2b27fb8f8 @stats={:processed=>59866, :failed=>58003, :scheduled_size=>0, :retry_size=>0, :dead_size=>9999, :processes_size=>1, :default_queue_latency=>0, :workers_size=>0, :enqueued=>0}> 

stats.queues
{dpms_queue=>0} 

Sidekiq::Status.status(2f4a2ba7dea9d42baaac968c)
:queued 

Sidekiq::Status::failed? 2f4a2ba7dea9d42baaac968c
false 

data = Sidekiq::Status::get_all 2f4a2ba7dea9d42baaac968c
{status=>queued, update_time=>1573162224, worker=>WebhookWorker, args=>[{\event\:\UPDATE\}], jid=>2f4a2ba7dea9d42baaac968c}

Som du kan se i statistikken, er det ingen jobb lagt i kø. Men når jeg får statusen til en bestemt jobb det er å bringe: kø.

Så, jeg lurer på hvorfor det er brigging i kø når det er ingen i Sidekiq statistikken? Og hvis det virkelig er lagt i kø hvorfor det ikke beeing behandlet?

Til slutt tror jeg det er en sideki-status bug.

Ps. Navnet jobbkøen er riktig.

Publisert på 03/12/2019 klokken 00:00
kilden bruker
På andre språk...                            


1 svar

SIDEKIQ JOBB Kunne men viser i kø i SIDEKIQ STATUS?

stemmer
0

Mitt problem er: Produksjonssystemet var oppdatering til ny versjon. Produksjonen sidekiq var det ikke. På grunn av dette ble ingen jobber behandlet i denne perioden. Etter at produksjonen sidekiq var oppdatering, alle kommende arbeidsplasser ble beeing behandlet på vanlig måte. Men alle tidligere jobber var det ikke.

Når jeg teste dette tilfelle i min lokale maskin alt som ble lagt i kø begynner å kjøre etter oppdateringen av sidekiq.

Nedenfor er den informasjonen som jeg fikk fra produksjon:

stats = Sidekiq::Stats.new
<Sidekiq::Stats:0x000055b2b27fb8f8 @stats={:processed=>59866, :failed=>58003, :scheduled_size=>0, :retry_size=>0, :dead_size=>9999, :processes_size=>1, :default_queue_latency=>0, :workers_size=>0, :enqueued=>0}> 

stats.queues
{"dpms_queue"=>0} 

Sidekiq::Status.status("2f4a2ba7dea9d42baaac968c")
:queued 

Sidekiq::Status::failed? "2f4a2ba7dea9d42baaac968c"
false 

data = Sidekiq::Status::get_all "2f4a2ba7dea9d42baaac968c"
{"status"=>"queued", "update_time"=>"1573162224", "worker"=>"WebhookWorker", "args"=>"[{\"event\":\"UPDATE\"}]", "jid"=>"2f4a2ba7dea9d42baaac968c"}

Som du kan se i statistikken, er det ingen jobb lagt i kø. Men når jeg får statusen til en bestemt jobb det er å bringe: kø.

Så, jeg lurer på hvorfor det er brigging i kø når det er ingen i Sidekiq statistikken? Og hvis det virkelig er lagt i kø hvorfor det ikke beeing behandlet?

Til slutt tror jeg det er en sideki-status bug.

Ps. Navnet jobbkøen er riktig.

Svarte 03/12/2019 kl. 00:00
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more