HAProxy / Docker: 502 Bad Gateway når treffer Docker container kjører Flask / React app

stemmer
0

Jeg prøver å Dockerize en Flask / React web-applikasjon for enkel utvikling / samarbeid, men har problemer med å få et skikkelig svar fra programmet. Jeg er i stand til å få bildet bygget og Flask serveren startet i en container, men har problemer faktisk treffer den.

Vi bruker HAProxy å videresende forespørsler, og ting fungerer fint når jeg har proxy og web server som kjører lokalt. Problemet har vært å få docker inn i miksen. Jeg tror det må være en port mapping problemet, men jeg er tom for ideer, og føler jeg kan mangle viktige HAProxy / Docker spissfindigheter. De proxy.cfg fil ser ut som følger (med fremmede verter ikke inkludert):

global
 maxconn 4096
 pidfile ~/tmp/haproxy.pid

defaults
 log global
 log 127.0.0.1 local0
 log 127.0.0.1 local1 notice
 mode http
 timeout connect 300000
 timeout client 300000
 timeout server 300000
 maxconn 2000
 option redispatch
 retries 3
 option httpclose
 option httplog
 option forwardfor
 option httpchk HEAD / HTTP/1.0


frontend dev
   bind *:8080 ssl crt ./proxy.pem

    acl allow_web path_beg /app/

    use_backend be_web if allow_web

backend be_web
 balance roundrobin
 server web_5000 localhost:5000

Dockerfile:

FROM node:10.6.0

RUN apt-get update
RUN apt-get install -y python-pip python-dev build-essential 

WORKDIR /usr/src/app

COPY ./package.json .
RUN npm install
COPY . .
RUN pip install -e ./server

CMD [npm, start]

Docker-compose.yml:

version: 3

services:
    userportal:
        build: .
        volumes:
            - /usr/src/app/node_modules
            - .:/usr/src/app
        ports:
            - 5000:5000

Kolben Serveren binder seg til port 5000 derav kartlegging. Jeg har prøvd å erstatte beholderen IP-adresse for localhost(f.eks 172.19.0.2:5000), men samme resultat.

Merk HAProxy kjører i sin egen terminal og er ikke inne i en container.

Publisert på 13/02/2020 klokken 21:59
kilden bruker
På andre språk...                            


1 svar

stemmer
0

Du bør kjenne din container IP på forhånd

docker inspect -f '{{range .NetworkSettings.Networks}}{{.IPAddress}}{{end}}' container_name_or_id

På et tidspunkt hvis du ønsker å bruke HAProxy det vil lettere å gjøre det inne Docker komponere til å avoir nettverksproblemer

Hvis du ikke ønsker at du kan prøve: haproxy.conf

global
  maxconn 4096
  pidfile ~/tmp/haproxy.pid

defaults
  log global
  log 127.0.0.1 local0
  log 127.0.0.1 local1 notice
  mode http
  timeout connect 300000
  timeout client 300000
  timeout server 300000
  maxconn 2000
  option redispatch
  retries 3
  option httpclose
  option httplog
  option forwardfor
  option httpchk HEAD / HTTP/1.0


frontend dev
  bind 0.0.0.0:8080 ssl crt ./proxy.pem   // <-- change wildcard with 0.0.0.0
  acl allow_web path_beg /app/
  use_backend be_web if allow_web
  default_backend be_web                  // <-- add this line

backend be_web
  balance roundrobin
  mode http
  option forwardfor                       // <-- add this line
  option httpchk GET / HTTP/1.1           // <-- add this line
  server web_5000 userportal_1:5000 check // <-- change localhost to the nane of running container "userportal_1" or the IP if you get it

Dockerfile:

FROM node:10.6.0

RUN apt-get update
RUN apt-get install -y python-pip python-dev build-essential

WORKDIR /usr/src/app

COPY ./package.json .
RUN npm install
COPY . .
RUN pip install -e ./server

EXPOSE 5000 // <-- add this ine

CMD ["npm", "start"]

Docker-compose.yml

version: "3"

services:
  userportal:
    build: .
    volumes:
      - /usr/src/app/node_modules
      - .:/usr/src/app
    ports:
      - "5000:5000"

Prøv å inkludere HAProxy i Docker-compose.yml vil hjelpe mye

Svarte 13/02/2020 kl. 22:56
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more