MAMP PRO PHP 5.3.5, Intl kreves av symfony2

stemmer
0

Symfony2 er satt opp bortsett fra en ting og det er intl

Jeg fant instruksjonene for å få dette arbeidet for den nyeste MAMP pro men trinnet 0 gir ikke mening for meg, jeg ignorerte det og prøvde å fortsette med oppsettet, men alt fungerer før jeg kommer til å make install, får jeg feil på den del.

Jeg kjører Snow Leopard.

http://szemian.wordpress.com/2011/03/21/compiling-intl-extension-for-mamp/#comments

etter at jeg har skrevet merke og det er gjort hva det har å gjøre jeg får denne meldingen på slutten:

make[2]: Nothing to be done for `all-local'.
make[0]: Making `all' in `test'
make[1]: Nothing to be done for `all'.
make[1]: Nothing to be done for `all-local'.

og etter at jeg velger make install får jeg denne meldingen:

make[0]: Making `install' in `stubdata'
/bin/sh ../mkinstalldirs /usr/local/lib
/usr/bin/install -c libicudata.46.1.dylib /usr/local/lib
install: /usr/local/lib/libicudata.46.1.dylib: Permission denied
make[1]: *** [install-library] Error 71
make: *** [install-recursive] Error 2

Kan noen råd til meg?

Publisert på 21/05/2011 klokken 10:04
kilden bruker
På andre språk...                            


1 svar

stemmer
1

På UNIX-systemer, du skal være administrator for å installere noe. Derfor bør du starte make installsom root (bruk sudo, jeg er ikke sikker på om rot eksisterer i Mac OS).

Når det gjelder trinn 0, hvorfor akkurat du er motvillige til å "Be kompilatoren til å kompilere i både 32 og 64 bit" arkitekturer?

Svarte 21/05/2011 kl. 11:16
kilden bruker

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more